-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|489|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
Socoder -> Console Coding -> OUYA-Forge-Flare

Thu, 10 Sep 2015, 06:11
Right, so I finally got me a Forge..

Plugged in, and set up, and all is ready to go.
(Tip : Your TV might have a USB socket, but that is NOT a suitable power output!! The Forge kept resetting, so I had to plug it into a proper charger, instead.)

Switching on the Forge takes me to the Android TV interface, where everything's locked down and all is enclosed.

I had to install a File Explorer, and fiddle about adding my network storage to it, but I can now compile an .apk, drag and drop it to my NAS, then open it using the File Explorer app, where it'll download and install it.
It's a little more faffing about than the OUYA's browser based approach, but it does at least work.

Since Forge is running in "Android TV Mode", it expects Android controller code.
If you've been testing and fiddling with Monkey->Android at all, you'll know that compiling for OUYA and compiling for Android are two VERY different things. Because of this, any OUYA games run from the Android TV frontend will simply NOT work with the controller.
(Anyone trying to get stock-Android things, and complaining about the controller not working on OUYA.. This is why!!)

I've emailed TeamOUYA asking about whether I'm supposed to be using an alternative OUYA Frontend, and am awaiting a response on that.

Other than that, though, all seems fine. If I compile "For Android", then the controller works just fine, other than that damn dpad, which is as stubborn as it is when using an XBox controller on your PC. I really don't know what's up with that!!
But all four face buttons are recognised, and in the correct places, as are the two shoulder buttons, and the two analogue sticks work just fine. The "Play/Pause" button works fine for Start, too.
The two analogue triggers, I haven't bothered to test, sorry!!

But that's my findings, so far. I'm going to wait for OUYA to get back to me on the whole "OUYA Mode" thing before going any further.

Note : Android TV doesn't have Overscan settings, so all the edges of the apps are slightly outside the border of my telly. *tsk tsk*

''Load, Next List!''
Thu, 10 Sep 2015, 08:36
OK, TeamOUYA's sent me a bunch of instructions to follow, but the first step is to hook the Razer up to the laptop using a USB A-A cable... Which I've had to order from Amazon, because a good rummage didn't find one. D'oh!!

''Load, Next List!''
Thu, 10 Sep 2015, 13:19
Where did you find one Jay? Might have to grab one of these also!

Web / Game Dev, occasionally finishes off coding games also!
Thu, 10 Sep 2015, 13:29
I emailed them with a set of test requests. Nothing too bad, just stuff like "run X game, and check that all the controls work" and "run Y game to ensure Z effect works on the new device".. That sort of thing.

Given the amount of testing, and my insane number of games, they ultimately decided it'd be quicker and easier to just send me one. Plus, I think someone there must actually like me, or something.

I've been told it's very much a special, one off sort of thing, so I don't think they're in the market for doling them out to everyone, I'm afraid.

I guess that having over thirty games on a console goes a long way.
.. And having a team of testers who CBA helps, too!

''Load, Next List!''
Thu, 10 Sep 2015, 13:32
Ahh, that's fair enough then, still cool that they sent you one over, that's very nice of them!

Web / Game Dev, occasionally finishes off coding games also!
Sun, 13 Sep 2015, 06:16
Got my controller *mostly* working, now, when compiling for OUYA. I've had to delve into the Monkey Template files, as well as update the .sdk, and do a few other bits and pieces (like completely disabling the Store functionality until I can figure it all out!), but a compiled OUYA edition now runs on Forge.

Again, all buttons except for that pesky DPad. I'm not sure what part of Monkey is ignoring DPads, but I guess I'm going to have to find out! Errk..

Once I've got everything working, I'll upload a new /target/ folder with all the newer SDK and stuff included. I should probably also send it to Mark, too, I guess.

''Load, Next List!''
Mon, 14 Sep 2015, 05:49
Got my dpad working.

Next stage, oh dear god help me....
I'll get TeamOUYA to double check things at their end, I think, and then make a start on recompiling all the 64,749,284,047,295 games with the new devkit updates.
Busy busy busy!!

''Load, Next List!''
Thu, 17 Sep 2015, 11:36
Additional faffing around..
Apparently having it "Just OUYA-Framework Ready" isn't quite good enough, so I've spent a fair amount of time, today, getting the controller code to work on Bog-Standard Android, too.
If you're a Monkey dev, you'll know there's Android target and OUYA target.
Compiling for Android means the controller code doesn't work on OUYA, and vice versa.

Well, now my "Android_Newya" target's controller code works on pretty much everything.
OUYA, Forge, Archos Gamepad.. They're all apparently working fine, and ... *fingers crossed* aren't quite yet exploding!

I have, however, completely killed the OUYAStore stuff, because, realistically, I'll never use it. It looked like a lot of arsing about to get that working, and I just couldn't be bothered in the slightest.

I'll get a couple of old games up and running, submit them to OUYA, and based on whether they're approved or not, will then post what I've done to the monkey/target.

''Load, Next List!''
Tue, 22 Sep 2015, 07:47
Right, here's something nobody warned me about.
If you compile an Android version, but DO NOT SIGN IT, it STILL GETS SIGNED......
there's a default signature based on your system, and if you don't back up that default, then you're as good as fucked.

So, having sent OUYA a request to kill/murder/destroy ALL of my games, I'm recompiling the whole lot and getting them back, ready for review again.
Meanwhile, I've sent the first test version to PlayJam (GameStick) and am waiting "my framework works or fails" results, there.

Busy busy busy!!!

''Load, Next List!''
Thu, 01 Oct 2015, 10:08
As I upload to OUYA, I'm also uploading to PlayJam/GameStick.
Today, they pushed the first 9 to their marketplace, all at once, leading to a homepage that looks a little like this..


''Load, Next List!''
Thu, 01 Oct 2015, 10:45

Sun, 04 Oct 2015, 05:48
Spent most of the past 24 hours trying to get my JMTrackr Music Engine working on GameStick.
Karl's Tiny Adventure uses it, and whenever I finish it, so does NeonPlat's Cosmic Adventure.
So.. Yeah, need that working, really.
And on all other test devices, it seems perfectly fine. .. But GameStick.

It seems to keep skipping notes, and missing bits out, and no matter what I do, I can't seem to figure out why.

So I asked PlayJam and they've suggested there's a physical hardware issue when it comes to playing sounds.
Hmm.. That doesn't help.
But it IS necessary, so I'll probably be spending the next few hours trying to figure out how to double-play notes, if they're skipped.

Really odd behaviour, but if it exists in one place, it likely exists elsewhere. Just because I haven't seen it, doesn't mean it's only limited to GameStick.
I only have 4 Android test devices.. OUYA, Forge, GameStick and Archos Gamepad, and we all know there's plenty of variety out there.

Gotta try to get everything working smoothly as I can.

... Grrr!!! Bloody Android!!

''Load, Next List!''
Sun, 04 Oct 2015, 13:33
Spent all day trying to figure this out, and it's still not working.


GameStick simply appears to be ignoring some PlaySound commands. Must be trying to do too much, or something. I dunno. Bloody thing.

''Load, Next List!''
Tue, 13 Oct 2015, 05:08
Apparently my upgraded "Very very very compatible" editions are failing to boot on the newer PlayJam device (The next-gen GameStick is named FlarePlay)

Quite what's breaking on them, I'm not sure, but I've been told they crash "After the GOTW Screen".. ...
.. *shudder*

I'll assume they mean "AGAW Screen"!!!

I wonder what's causing it?
My new Controller code?
A problem with using large assets?
The fact that there's leftover OUYA stuff in there?

I'm not sure..
Could be any number of things, if I'm honest.

So, how to stress test all possible avenues..?

> Reveal 🔎

''Load, Next List!''
Tue, 13 Oct 2015, 07:42
AquaVenture on the FlarePlay has reversed analogue controls, but other than that it works well. :/
Tue, 13 Oct 2015, 09:27
Reminds me I need to have a chat to Playjam about porting Super Grid Run across to it.

Web / Game Dev, occasionally finishes off coding games also!
Wed, 14 Oct 2015, 12:06
OK, a couple of issues "maybe"..

Issues are in one of two groups.
1. "Freeze"
Whereby the game loads up to the main menu, then appears to completely freeze. This isn't an actual freeze, it's just that the game isn't recognising the controller, so it might as well have frozen up.

2. "Crash"
Whereby the game doesn't even reach the main menu.
This is due to the system having not loaded the AGameAWeek Jingle, before it tries to play it, thus going "OH FUCK!!" and crashing like a baby.

... Even though there's a 4 frame gap between it being told to load the sound, and when it plays it, because I figured that'd probably be an issue when I added it!!


At first I struggled to replicate either of these on the device, but the more I tried different games, the more "broken" they started to get.
At which point I realised the cause of most of the issues.

Far from being my fault (mostly) it seems that the devkit is leaving things running, multitasking in the way that Android typically does.
As more and more layers get added on, the foreground task starts to suffer, and .. well, it's Android.. Everything eventually breaks!

I've never encountered this on my other Android devices, but then I'm the sort of user who constantly finds himself closing everything before opening the next thing. Heck, I even do that on my iOS devices, even though technically you aren't supposed to keep closing apps on there!!

But having plugged the Flare DevKit in, and it not having a quick "close the apps" method, I was adding more and more and more into the system, and nothing was being closed.

Note to all, if anything's running like ass on your Android, close everything and try again!

I've been assured that the retail edition will feature the same "Close every other app" functionality that the current GameStick and OUYA use. It's just the DevKit that's doing this.
I'm still going to have to faff about with Controllers again, to see if I can get multiplayer and other ports working, and will also be delaying audio playback until the files are definitely loaded!!

.. But.. Yeah, learned a lot, this week!

''Load, Next List!''
Thu, 15 Oct 2015, 14:13
Having a hell of a time working out standard Android multiplayer code, mostly due to my Archos Gamepad..
For some bizarre reason, it's treating the dpad and face buttons as a different controller to the analogue sticks, which is causing all manner of issues.
It's "mostly" working for other controllers.. I'm wondering if I should see about faking it on the Archos... Hmm...

''Load, Next List!''
Thu, 15 Oct 2015, 23:59
Android - the one size fits all OS that's completely different and broken on all devices. :/
Fri, 16 Oct 2015, 00:18
Another couple of hours, this morning.. Still no luck.
Very confusing...

''Load, Next List!''
Tue, 17 May 2016, 05:55
So, FlarePlay is dead and they're issuing refunds and trying to get the hardware back. Is it that tied into the service?

All the raw, animal magnetism of a rutabaga.
Tue, 17 May 2016, 09:01
Tue, 17 May 2016, 09:11
Maybe it's mentioned and I can't read but what's FlarePlay?