-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|351|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
Socoder -> Off Topic -> AGAWFrame

Page : 1 2 3 4 5 Prev 6 7 Next 8 9
Posted : Monday, 06 November 2017, 07:04
rockford
Works fine here.
Posted : Tuesday, 07 November 2017, 14:26
Jayenkai
I got Ogg streaming (hopefully) working, today, which is nice.
I tried getting mod playing to work, yesterday, but it's one of those "Simply compile the library to run!!!!" things, where no matter how hard you try, it just won't fucking well compile...
So, today I thought "Screw that for now" and decided to get Ogg streaming to work, instead.

Download the test here.

Music plays.
Up and Down alters the pitch.
Nothing else much added, to speak of.

Hold N and Up to stress it as much as possible. It'll probably stutter a bit, under those circumstances, but otherwise should be a nice steady stream of music.

Let me know if it isn't!

-=-=-
''Load, Next List!''
Posted : Wednesday, 08 November 2017, 00:52
therevillsgames
Works okay here and at work. But the FPS at work was only 20FPS.
Posted : Wednesday, 08 November 2017, 01:13
Jayenkai
Was it previously quicker, or is it something to do with the Ogg support?!
.. and does hitting F11 to switch to fullscreen make it any better?

-=-=-
''Load, Next List!''
Posted : Wednesday, 08 November 2017, 02:57
rskgames
Everything is working fine with ogg streaming. Did not see the FPS issue in either the windowed or the full screen mode.

-=-=-

Posted : Wednesday, 08 November 2017, 07:56
rockford
Getting 27FPS and stuttering on my machine here.

It is an extremely old lappy (and I believe there is something going on with my machine anyway), but it handles many newer games OK. I was also downloading lots of individual files and had many tabs open in my browser while this was running, but that's par for the course...
Posted : Wednesday, 08 November 2017, 08:12
Jayenkai
Is that with or without holding Up+N?
Posted : Wednesday, 08 November 2017, 08:51
rockford
Without.
Posted : Wednesday, 08 November 2017, 09:12
Jayenkai
Dun-dun-durrr...
OK, definitely the Ogg player that's doing that.
.... I think!

Next test should be up later tonight, I think, and I'll probably add some kind of debug.txt output.

-=-=-
''Load, Next List!''
Posted : Wednesday, 08 November 2017, 09:25
rockford
More likely my lappy, but it'll be good for you to know.

I'm on nights ths week, so probably won't be able to try the test later.
Posted : Wednesday, 08 November 2017, 09:39
Jayenkai
It'll still be here once you have any time. And there's oodles of folk testing, so don't worry if you don’t get the time.
Poor Rockford

-=-=-
''Load, Next List!''
Posted : Wednesday, 08 November 2017, 10:11
Pakz
Runs fine here also. With the max amount of particles I get 30fps. Does it automatically start with the powerfull gpu? I noticed that if I start it with the 1050 using the windows popup the game takes a little longer to start.
Posted : Wednesday, 08 November 2017, 11:15
Dabz
Works a charm here!

Dabz
Posted : Wednesday, 08 November 2017, 13:01
steve_ancell
Without pressing anything: Update 60FPS - Render 60FPS - Polys 436.

Press Z: Update 60FPS - Render 60FPS - Polys 732.

Press x: Update 60FPS - Render 60FPS - Polys 1230.

Press C: Update 60FPS - Render 60FPS - Polys 2234.

Press ZXC: Update 60FPS - Render 60FPS - Polys 2234.

Without pressing anything: Update 60FPS - Render 60FPS - Polys 436.

Press Z: Update 60FPS - Render 60FPS - Polys 732.

Press x: Update 60FPS - Render 60FPS - Polys 1230.

Press C: Update 60FPS - Render 60FPS - Polys 2234.

Press V: Update 30FPS - Render 30FPS - Polys 5234.

Press B: Update 30FPS - Render 30FPS - Polys 10240.

Press N: Update 16FPS - Render 30FPS - Polys 20232.

Press ZXCVBN: Update 16FPS - Render 30FPS - Polys 20244.

Arrow Keys change the music speed and background colour, but don't effect the update or render.

System:
Mobo ASUS M5A78L-M/USB3
Processor AMD FX8320 8-Core @ 3.5GHZ
16GB RAM
Graffix AMD Radeon R9270 : Memory 4095MB (fucking hell this card is shit! )
Posted : Wednesday, 08 November 2017, 13:49
Jayenkai

Proper Benchmark Time!


If you can, please give this benchmarker a run.

It's a simple little tool.
Unzip it, run the .exe, and watch as three "Bloke" sprites circle around for a little while.
Don't touch anything. The benchmark tool will do it all for you.
Running through a bunch of sprite-pushing tests, blending methods, and audio streaming, too.
It'll also flip to fullscreen to check there, too, so be warned if you're watching any other media on your PC at the time!!!

Once it's done (about a minute and a half) it'll leave a debug.txt file, which you should send my way.
Thanks for testing!

-=-=-
''Load, Next List!''
Posted : Wednesday, 08 November 2017, 14:05
steve_ancell
You mean this!...

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5066
Added Blend Modes took 5016
Oodles of Sprites took 5017
Oodles of Alt-Blended Sprites took 5018
Boatloads of Sprites took 6184
An Insane Number of Sprites took 10020
Streaming Wave took 5035
Streaming Ogg took 5012
Fullscreen - Oodles of Sprites took 5016
Oodles of Alt-Blended Sprites took 5017
Boatloads of Sprites took 5019
An Insane Number of Sprites took 8894
Rotated Sprites took 7483
Streaming Wave took 4993
Streaming Ogg took 5013
Posted : Wednesday, 08 November 2017, 14:22
Jayenkai
Perfick!
Posted : Wednesday, 08 November 2017, 14:30
rychan
Here's my results:

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5055
Added Blend Modes took 5028
Oodles of Sprites took 5025
Oodles of Alt-Blended Sprites took 5031
Boatloads of Sprites took 5283
An Insane Number of Sprites took 9985
Streaming Wave took 5012
Streaming Ogg took 5012
Fullscreen - Oodles of Sprites took 5088
Oodles of Alt-Blended Sprites took 5650
Boatloads of Sprites took 14981
An Insane Number of Sprites took 24981
Rotated Sprites took 15131
Streaming Wave took 5058
Streaming Ogg took 5015

-=-=-
Web / Game Dev, occasionally finishes off coding games also!

Refresh Games - Game Dev Blog
Posted : Wednesday, 08 November 2017, 14:52
Pakz
On the new Asus Rog Laptop

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5018
Added Blend Modes took 5014
Oodles of Sprites took 5015
Oodles of Alt-Blended Sprites took 5014
Boatloads of Sprites took 5018
An Insane Number of Sprites took 5148
Streaming Wave took 5010
Streaming Ogg took 5004
Fullscreen - Oodles of Sprites took 4976
Oodles of Alt-Blended Sprites took 5016
Boatloads of Sprites took 5016
An Insane Number of Sprites took 9965
Rotated Sprites took 5090
Streaming Wave took 4979
Streaming Ogg took 5006
Posted : Wednesday, 08 November 2017, 19:11
therevillsgames
and does hitting F11 to switch to fullscreen make it any better?

Fullscreen I get an extra 5/6 FPS so 25FPS compared with windows 20FPS.


My Work's PC:

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 9962
Added Blend Modes took 14959
Oodles of Sprites took 10144
Oodles of Alt-Blended Sprites took 11017
Boatloads of Sprites took 15127
An Insane Number of Sprites took 20962
Streaming Wave took 10168
Streaming Ogg took 10090
Fullscreen - Oodles of Sprites took 10229
Oodles of Alt-Blended Sprites took 11966
Boatloads of Sprites took 18582
An Insane Number of Sprites took 29966
Rotated Sprites took 20178
Streaming Wave took 6491
Streaming Ogg took 6584

I also noticed "Buffer Error" when playing the music in the command box.
Posted : Wednesday, 08 November 2017, 22:44
Dabz
Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5017
Added Blend Modes took 5021
Oodles of Sprites took 5021
Oodles of Alt-Blended Sprites took 5021
Boatloads of Sprites took 5020
An Insane Number of Sprites took 5039
Streaming Wave took 5024
Streaming Ogg took 5017
Fullscreen - Oodles of Sprites took 5036
Oodles of Alt-Blended Sprites took 5020
Boatloads of Sprites took 5021
An Insane Number of Sprites took 5023
Rotated Sprites took 5019
Streaming Wave took 4973
Streaming Ogg took 5017

Dabz

-=-=-
Intel Core i5 6400 2.7GHz, NVIDIA GeForce GTX 1070 (8GB), 8Gig DDR4 RAM, 256GB SSD, 1TB HDD, Windows 10 64bit
Posted : Thursday, 09 November 2017, 01:22
therevillsgames
And Home PC:

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5019
Added Blend Modes took 5016
Oodles of Sprites took 5017
Oodles of Alt-Blended Sprites took 5017
Boatloads of Sprites took 5015
An Insane Number of Sprites took 5034
Streaming Wave took 5013
Streaming Ogg took 5012
Fullscreen - Oodles of Sprites took 5038
Oodles of Alt-Blended Sprites took 5016
Boatloads of Sprites took 5018
An Insane Number of Sprites took 5017
Rotated Sprites took 5016
Streaming Wave took 4989
Streaming Ogg took 5015
Posted : Thursday, 09 November 2017, 01:36
rskgames
Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5031
Added Blend Modes took 5032
Oodles of Sprites took 5017
Oodles of Alt-Blended Sprites took 5016
Boatloads of Sprites took 5069
An Insane Number of Sprites took 10117
Streaming Wave took 5025
Streaming Ogg took 5019
Fullscreen - Oodles of Sprites took 19104
Oodles of Alt-Blended Sprites took 5015
Boatloads of Sprites took 5018
An Insane Number of Sprites took 6523
Rotated Sprites took 10025
Streaming Wave took 5030
Streaming Ogg took 5003

-=-=-

Posted : Thursday, 09 November 2017, 03:08
Jayenkai
Thanks for all Testing so far.
Seems like most all systems are capable of at least "oodles" of sprites, which is nice.
As for TheRevillsGames' work PC, well.. that’s a bit pants, isn’t it!!?
Happy to see, however, that the error-filled audio buffer tests still managed to perform at about the same speed as the None-audio buffer tests, so I think I can rule out the audio streaming as the cause of that.

Further testing to come. For now I need to build some more functionality, and worry about the fact that, so far, this is only running on Windows!!!

-=-=-
''Load, Next List!''
Posted : Thursday, 09 November 2017, 06:01
Pakz
I tried the benchmark on the Amd-a8 laptop. I noticed a list of buffer errors with the ogg test.

Here the debug log :

Jay's Magical Benchmark
-=-=-=-
Practically nothing took 5187
Added Blend Modes took 7320
Oodles of Sprites took 6069
Oodles of Alt-Blended Sprites took 9153
Boatloads of Sprites took 12644
An Insane Number of Sprites took 16201
Streaming Wave took 6841
Streaming Ogg took 6458
Fullscreen - Oodles of Sprites took 5731
Oodles of Alt-Blended Sprites took 6218
Boatloads of Sprites took 10694
An Insane Number of Sprites took 17556
Rotated Sprites took 12942
Streaming Wave took 5082
Streaming Ogg took 5033
Page : 1 2 3 4 5 Prev 6 7 Next 8 9