-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|511|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
Socoder -> Monkey -> GLFW graphical garbage on OS X latest updates

Wed, 06 Dec 2017, 07:10

GLFW graphical garbage on OS X latest updates

Hi there.
I was wondering if anybody here is using Monkey-X/CerberusX to build GLFW games on OS X and if so, are you up to date on the OS X updates and are you having any graphical issues?

Initially I thought this was Monkey-X doing something weird, but I downloaded the lastest XCode from the app store and compiled fine.
The game launches, you can navigate around the menu and hear audio, but graphics are garbadged.
So I loaded the project directly inside XCode and ran it from there and exactly the same issue occurred.
No build errors anywhere to be seen but garbadged graphics.
I'm not at home right now to screenshot it but will update this thread later when I go.

PS. the game builds and runs fine on Windows and Linux.
PPS. This also happens with any Bananas examples.

I think I'm on High Sierra 10.13.1 or something, but since I've not built my game on my Mac for almost a year, I'm not sure if/which update could've broken things.
I'm also compiling to GLFW3 and wonder if that's the problem. Thing is, I don't have the option/ability to compile to GLFW2. Any ideas on how to add/chnage that? I suspect that might solve the problem..

Any suggestions or ideas would be welcome too.

Wed, 06 Dec 2017, 07:38
Is it polygons or images that are mangled?
As in, if you draw a plain tri, is that messed up, or is it only once you add images?
And from there, what happens if you switch format from png to jpg (or vice versa)
Could just be that the image loader, for unknown reasons, has broken along the way.

Oh. And welcome aboard!

''Load, Next List!''
Wed, 06 Dec 2017, 11:42
MonkeyX wil not be repaired anymore(only maybe with large donations) Have you tried asking on the Cerberus forums?


They also have a discord channel. Not sure how to invite etc. There was a post in the general discussion forums where I was able to paste a invite in.

And, I installed MonkeyX pro on a new system recently(win10) and I now get a couple of error messages when compiling. Everything still runs though.
Wed, 06 Dec 2017, 16:00
Hi guys,

Thanks for the comments.

Apologies in advance if we're not allowed to cross-link forums, but I got it resolved on CSyntaxbomb: https://www.syntaxbomb.com/index.php/topic,3845.0.html

Basically, it appears to be Monkey-X hasn't been updated whereas Mike Hart said Cerberus X has been updated. So I gave it a try and it works now, yay!