-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|550|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
SoCoder -> Blogs Home -> Blogs


 
JL235
Created : 11 March 2011
Edited : 24 March 2011
System : Mac

PlayMyCode Embedding!



Thanks to Jay (thanks) you can now embed PlayMyCode games here on SoCoder. YAY! \o/

For this you can use the new [ pmc ] tag. When you go to embed or share a game the url ends with 'username/title'. For example Spike Dislike's url is https://playmycode.com/play/embed/Jayenkai/Spike+Dislike ' and so ends with 'Jayenkai/Spike+Dislike'. You put that end bit between the pmc codes, like so:

[ pmc ]Jayenkai/Spike+Dislike[ / pmc ]

(but without spaces).

Here is a Swirly demo Jay made (click on the screen)

.. and here is jumping game someone else made (who isn't me or Jay)


Next up, Wordpress!

 

Comments


Friday, 11 March 2011, 11:53
shroom_monk
Is PMC down? All I see are Chrome's 'this page is not available' pages inside those boxes...
Friday, 11 March 2011, 12:12
JL235
It's working fine for me. Is it still doing this for you?
Friday, 11 March 2011, 12:22
shroom_monk
It's still down for me. Even opening the link it's giving that it can't reach (https://www.playmycode.com/play/embed/Jayenkai/Swirly2) gives a 'Chrome could not find' error.
Friday, 11 March 2011, 12:51
JL235
What version of Chrome are you running? Is it only Chrome that is affected?

Is anyone else experiencing this?
Friday, 11 March 2011, 12:58
Jayenkai
Working fine for me... *shrugs*
Friday, 11 March 2011, 13:37
shroom_monk
Doesn't work in IE either. I just can't seem to access the playmycode website from my internet connection at all, which is odd, because I certainly used to be able to.
Friday, 11 March 2011, 14:08
Jayenkai
Eek!!?
Friday, 11 March 2011, 14:14
JL235
I did change the .htaccess file earlier so anything starting with https://playmycode.com redirects to https://www.playmycode.com. I think this has broken it for you. However again you seem to be the only person affected by this!

At a guess I'm wondering if it's a DNS issue? Could you try opening a cmd window and typing 'ipconfig /flushdns'.
Friday, 11 March 2011, 14:38
shroom_monk
Flushing the DNS did nothing, and I can't access with of playmycode.com or www.playmycode.com. I guess it's just a DNS issue with my provider or something? :/
Friday, 11 March 2011, 15:29
JL235
Both 'playmycode.com' and 'www.playmycode.com' are now the same. Going to the former redirects you to the latter, that's the change.

I'm interested if you can actually find the server. Try visiting the logo directly, first at: www.playmycode.com/images/logopink.png and then the ip version: 67.43.13.30/~lentons/images/logopink.png

Could you also please try in cmd ...

If that can't find it then it's (almost) certainly a DNS issue as it won't be hitting my .htaccess file. It might just resolve itself by tomorrow as DNS caches expire and update.

... and you could try the age old restarting your PC!
Friday, 11 March 2011, 16:09
shroom_monk
The direct logo link with the address does not work, but with the IP it does! Pinging also fails, as it could not find the host.

I'll see what it's like tomorrow!
Thursday, 17 March 2011, 06:11
JL235
So... is this working now?
Friday, 18 March 2011, 11:54
shroom_monk
It wasn't for a few days, but I checked just now and it is!