123
-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|530|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
Socoder -> C/C++/C#/Other -> Anyone any good at java?

Tue, 03 Jan 2023, 12:26
spinal

Anyone any good at java?


I want to have a go at using the android project here https://www.hackster.io/mitchwongho/read-phone-notifications-using-esp-eb0ad4 on my phone to do exactly as the project intends, send messages over Bluetooth.

However, I don't know java (won't be a problem yet) but worse, the project 'as-is' doesn't build in android studio. Googling the build errors gives no useful info.
Is anyone here will to load up the project and clue me in on what I need to do to build the app?

Kindest regards,

Me.

-=-=-
Check out my excellent homepage!
Wed, 04 Jan 2023, 04:04
Jayenkai
Did you find any solutions for this?
I've been trawling the net, but haven't found anything more useful than "Just install these several hundred SDKs"
The last time I dared anything Java was back when I did OUYA dev, and .. gosh, that's a long time ago, now!

I DO remember finding things easier once I installed a Linux secondary boot on my system, though. I wonder if there's an easy to use Linux Distro that includes all the necessary Android Studio gubbins, pre-installed on an easy to use thumbdrive booting, ready to use, live instance..?

-=-=-
''Load, Next List!''
Wed, 04 Jan 2023, 04:50
therevillsgames
Did you also clone the dependency noted on the readme?
Wed, 04 Jan 2023, 12:40
spinal
So, I downloaded the main project zip, extracted it, downloaded the ble depencency, extracted that.
Imported the project into Android Studio.
Tried to build it, android studio suggested some updetes, I dd those.

Now I'm up to
"The 'kotlin-android-extensions' Gradle plugin is deprecated. Please use this migration guide (https://goo.gle/kotlin-android-extensions-deprecation) to start working with View Binding (https://developer.android.com/topic/libraries/view-binding) and the 'kotlin-parcelize' plugin."

I theory I follow the instructions in the link, in practace though, I don't have the slightest idea what its talking about.

-=-=-
Check out my excellent homepage!
Wed, 04 Jan 2023, 12:47
Jayenkai
There should be rule that, before uploading anything to Github/StackOverflow/etc (and here!!), the author must first create a VirtualMachine, and try to get it to run, again, from scratch..

-=-=-
''Load, Next List!''
Wed, 04 Jan 2023, 12:54
spinal
I think the code is a few years old though.

|edit|
semi related - this would have made a nice case for my nearly smart nearly watch -- https://www.amazon.co.uk/dp/B09BDZ2PPM/?coliid=I1Z7TB7KLAUYRS

-=-=-
Check out my excellent homepage!
Wed, 04 Jan 2023, 13:08
Jayenkai
Cool!
SpinalWatch 2!!!
Wed, 04 Jan 2023, 13:53
spinal
OK, maybe a bit further, changed the ext.kotlin_version to 1.7.0 in build.gradle...



|edit| OK, a little further, but still completely lost...



causes



And I haven't the faintest idea what that means.

-=-=-
Check out my excellent homepage!
Wed, 04 Jan 2023, 14:18
therevillsgames
@Jay, VMs are so old hat now, should use a docker container instead
Wed, 04 Jan 2023, 14:26
Jayenkai
*shrugs* I'm used to oldskool methods.. If I could Goto 1980, I would do!

-=-=-
''Load, Next List!''
Wed, 04 Jan 2023, 14:30
spinal



View on YouTube

-=-=-
Check out my excellent homepage!
Wed, 04 Jan 2023, 14:33
Jayenkai


-=-=-
''Load, Next List!''
Wed, 04 Jan 2023, 15:58
AndyH
Syntax Error on line 20
READY
[]
Wed, 04 Jan 2023, 16:33
Jayenkai
Yeah, sorry, I went all GotoJSE there, didn't I! Oops!!

-=-=-
''Load, Next List!''